Helm Registry registry.element.io/helm access issues

Incident Report for Element

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 11:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 10:46 UTC

Investigating

Users are reporting an issue in accessing our helm registry. We are actively working on fixing the issue.
Posted Dec 05, 2025 - 09:29 UTC
This incident affected: Image Registry (registry.element.io).