Email delivery issues
Incident Report for Element
Resolved
This incident has been resolved.
Posted Aug 23, 2024 - 07:24 UTC
Identified
Emails are currently not being delivered from the customer dashboard or EMS hosted homeservers. This affects registration of new accounts and delivery of email notifications for cloud homeservers.
Posted Aug 20, 2024 - 08:46 UTC
This incident affected: EMS dashboard, Element One and Cloud hosting regions (London hosts, Frankfurt hosts, Ohio hosts, Stockholm hosts).